Environment Details
When attempting access Vanta using an Okta login, you are encountering an error page stating "Vanta encountered a problem"
Cause
The Vanta Okta Application has not been completely connected.
Resolution
- Sign into Vanta as an Administrator and navigate to the Integrations Page
- Find 'Okta' on your connected integrations, and click the 'Manage' button. Click 'Edit' on the drop down
- Next, click the Pencil icon to the right of your Okta account
- If the integration was not corrected completely, the popup will display with the error message "The Vanta Okta Application is not connected. Vanta users are unable to log into Vanta via Okta. To enable this, follow the steps below and then reconnect."
- Add the Vanta integration by following this Okta guide. Your domain ID can be copied from the popup.
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Once the app has been successfully connected, go to your Okta dashboard to configure visibility to user groups in your organization.Users will need to be assigned the Vanta app in Okta to be able to log in to Vanta with Okta. More info here.
Note: if you don't see the error message when editing the Okta app, please email us at support@vanta.com to investigate other possible causes.