Jira security Tasks not Syncing to Vanta - Troubleshooting

  • Updated

Environment Details:

Once you connect a Task Manager to Vanta, We pull tasks that you've created with a 'security' tag or, in Jira's case, Label. The Labels field is a default field in Jira that allows you to add tags. We look through all the Projects the connecting user has permission to view and fetch all tasks with a
security label on them. 

If Vanta can't view any of the tasks created with a security label, records of security issues being tracked will fail, and no test data will be available for export:

However, the other resources may still fetch, such as Accounts, Projects, Sprints, etc.. 

 

Example


 

 

Possible Cause

Despite Vanta being able to see your Projects and other resources like Accounts, We may not have permission to view Tasks on some or all of your Projects. This can be confusing because the integration shows no error messaging in Vanta, and appears to be working as expected. 

Attempt to confirm that the Jira Account used to connect Jira to Vanta is the appropriate account with the required permissions to view Tasks created on those Projects. The account you've used may be able to see all of your Projects but could have restrictions on viewing the Tasks within them.

 

Resolution 

  • Confirm that the security tasks you've created have the appropriate Label:
    How to Label Security Tasks in Jira
  • Confirm the Account used has the required permissions to view Project tasks: How to connect Team-managed software and Company-managed business projects to Vanta
  • Attempt to reconnect Jira to Vanta in an incognito browser window. This is to make sure there aren't any pre-existing site data or cookies interfering with the process.
  • If the User you're using to connect is part of an Organization, make sure that the permissions extend to all other Jira Projects that have security tasks created in them.

If you've tried the above troubleshooting steps, but are still experiencing issues, Don't hesitate to contact our Support Team! We'd be glad to help.

 

Additional Resources

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