Error: User added to Office365/Azure AD not visible on People Page

  • Updated

Environment Details

 

When connecting Office365 as your Identity provider, Vanta will automatically fetch employees to the people page in Vanta if no existing user profile is found. New employees created in Office365 should populate when the integration next syncs. 

 

If the employee is not visible in Vanta within 24 hours, this likely means an issue with Vanta fetching the user profile from Office365.

 

Cause

 

This can occur if the email field has not been populated in the employees Azure AD profile

Screenshot_2023-04-06_at_10.50.52_am.png

 

Resolution

  1. Log into Azure AD Directory and access 'Users' > 'All Users'"
    Screenshot_2023-04-06_at_10.43.33_am.png
  2. Search for the employees name and click to access the overview. Click on 'Edit Properties'
    Screenshot_2023-04-06_at_10.53.01_am.png

  3. Search for 'Email', or scroll to the email field. If blank add the employees email address and save
    Screenshot_2023-04-06_at_10.57.50_am.png

  4. The user should be visible on the People Page the next time the integration Syncs. It's normal for this to take a few hours, but should be no more than 24 hours. If the employee is still not on the people after 24 hours, please contact support@vanta.com for further assistance.

 

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