Error: “The Azure credentials are invalid. Check the correct values are being used”

Chris B.
Chris B.
  • Updated

When re-connecting the Azure integration, administrators can encounter a The Azure credentials are invalid.

 

"Check the correct values are being used” error. This can occur even after it looks like the integration has been successfully connected. 

mceclip0.png


Cause

 

One of the most common reasons for this is an invalid client secret being provided. This leads to Vanta to 401 errors when attempting to access to the token. To resolve this, administrators must ensure the secret being added to Vanta is the client's secret value,  and not the client's secret ID for the failing subscription. 

 

Resolution

  1. You must delete the current key by going to the Vanta App Registration you created when connecting the integration. Search for App Registration in the search bar and select it under Services

    mceclip1.png

  2. Scroll down and select the Vanta App, and then click Certificates & Servers, then delete the existing key 




  3. Once that is complete, generate a new secret by clicking + New client secret 



    Once the new secret is generated, do not leave this page!  You WILL NOT be able to see the value again, so please leave this page open. Otherwise, you will need to generate a new key. 

  4. Wait a minimum five minutes and up to 15, then head back into Vanta, and attempt to connect the integration again. On the second step, when prompted by Vanta, copy the client secret value from this page and enter it

    mceclip2.png

     
  5.  If the integration continues to fail, it is likely another error; please write to Vanta support and mention you tried the steps in this article. 

 

Additional Resources