Environment Details
When attempting to access Vanta using an Okta login, you encounter an error page stating, "Vanta encountered a problem."
Cause
The Vanta Okta Application has not been fully connected.
Resolution
Sign in to Vanta as an Administrator and navigate to the Integrations Page
Find 'Okta' on your connected integrations, and click the 'Manage' button. Click 'Edit' on the drop-down
Next, click the Pencil icon to the right of your Okta account
If the integration is not corrected completely, the popup will display the error message The Vanta Okta Application is not connected. Vanta users are unable to log into Vanta via Okta. To enable this, follow the steps below and then reconnect.
Add the Vanta integration by following this Okta guide. Your domain ID can be copied from the popup.
Once the app has been successfully connected, go to your Okta dashboard to configure visibility to user groups in your organization.
To log in to the Vanta app with Okta, users will need to be assigned the Vanta app in Okta. More info is here
Please note: if you don't see the error message when editing the Okta app, please email us at [email protected] to investigate other possible causes.