Environment Details
After integrating AWS, you see the following error for resources on the inventory page:
Could not fetch [Resource] for region "[Region]" for account "xxxxxxxxxxxx": InvalidClientTokenId: The security token included in the request is invalid
Cause
You have selected an AWS region to be scanned in Vanta, but this region is not enabled in AWS.
Resolution
- Sign in to the AWS console
- Select the region selector from the top right:
- Ensure that the regions that are not enabled in AWS are not selected in Vanta. To do this, navigate to the integrations page in Vanta and select "Manage" for AWS. Select an account to edit the region selection for:
- Ensure that the regions selected in Vanta are enabled in AWS:
- Click Done to update the regions