User added to Office365 & Entra ID not visible on People Page

  • Updated

 

When connecting Office 365 as your Identity provider, Vanta will automatically fetch employees to the people page in Vanta if no existing user profile is found. New employees created in Office 365 should populate when the integration next syncs.

If the employee is not visible in Vanta within 24 hours, this likely means an issue with Vanta fetching the user profile from Office 365.

 

Cause

  • This can occur if the email field has not been populated in an employees' Entra ID profile

 

Resolution



  • Search for the employee's name and click to access the overview.
  • Click on Edit Properties




  • Select 'Contact Information' and look for the 'Email' field. If blank, add the employee email address and save




  • The user should be visible on the People Page the next time the integration Syncs. It's normal for this to take a few hours, but it should be no more than 24 hours. If the employee is still not on the people after 24 hours, please contact support@vanta.com for further assistance.

 

Additional Resources