Error: Users not showing as passed for KnowBe4 security awareness training

  • Updated

Users are utilizing KnowBe4 for Security Awareness Training (SAT), which integrates with Vanta to track the completion of the training and compliance. Employees who are confirmed to have completed the SAT in KnowBe4 are flagged in Vanta as not having completed the SAT.

Causes

  • Users do not have the correct KnowBe4 campaign configured in their Integration profile
  • Employee's emails do not match between KnowBe4 and Vanta, this will make it so the training cannot be linked to the proper profile in Vanta. 

Resolution

Users do not have the correct KnowBe4 Campaign configured

  • Review Integrations by checking  Integrations > KnowBe4 > Manage > Edit > Add campaign
  • After the campaign is configured, the users should reflect as passing their security awareness training in Vanta.

 

Mismatched emails - to update an email in KnowBe4 so it matches its counterpart in Vanta:

  • Log into KnowBe4, navigate to the Users tab
  • Select the dropdown arrow next to that user, click edit
  • Once updated, click update user
  • Once updated, the completed training should appear for that user in Vanta shortly after.